This incident has been resolved. Affected unsubscribe events have been replayed. And as noted before, inbound subscriptions during the incident period can not be replayed.
Posted Apr 24, 2025 - 19:13 EDT
Monitoring
We have observed recovery of affected systems.
We are in the process of replaying affected unsubscribe events, and other remaining queued events have been processed. Event processing, API responses, and latency are all up-to-date. Unfortunately, inbound subscriptions during the affected period can not be replayed.
We will provide another update once unsubscribe events have been replayed.
Posted Apr 23, 2025 - 18:01 EDT
Identified
We have addressed the underlying issue. We are seeing improvement in event processing, API responses and latency, email sending, and other areas.
We are continuing to work on fully restoring normal operations.
Posted Apr 23, 2025 - 15:41 EDT
Investigating
We are experiencing disruption in event processing since 2pm EST. Customers may see high error rates with APIs, missing metrics, and delayed sending.
We are investigating the issue and working to mitigate it currently.