Delays in Email Sending

Incident Report for Klaviyo

Resolved

We can confirm that all delayed emails have caught up as of approximately 7:15 PM US Eastern, and email sending is back to real time.
Posted Apr 23, 2025 - 19:53 EDT

Investigating

Beginning around 5 PM US Eastern time, we began observing delays in email messages sent by a mail delivery partner. In addition to a subset of campaign and flow messages, this may affect emails for multi-factor authentication login and double opt-in emails.

Mail is being accepted and processed, but is delayed; we do not expect data loss. We will provide further updates as we have them.
Posted Apr 23, 2025 - 18:06 EDT
This incident affected: Email Sending (Campaign Email Sending, Flow Email Sending).