We have confirmed the app is now widely available and are moving the incident to monitoring.
10% of accounts experienced messaging delays during this window. We are working to replay any impacted messages, including unsubscribes, inbound SMS, and flows. Any campaigns that failed during this time will need to be manually resent. We will continue to monitor system performance.
Posted Dec 22, 2025 - 18:58 EST
Update
We identified broader service disruption across the Klaviyo app between 5:55 pm and approximately 6:10 pm ET. While initial reports were limited to account switching, we have since confirmed additional impact to app availability and functionality.
The underlying issue has been addressed, and the app is now available. Some customers may continue to experience intermittent issues as systems fully recover. We are actively monitoring.
Posted Dec 22, 2025 - 18:37 EST
Investigating
We are investigating reports of users unable to switch accounts once logged into Klaviyo