Data processing delays

Incident Report for Klaviyo

Resolved

This incident has been resolved.
Posted Dec 18, 2025 - 01:36 EST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Dec 18, 2025 - 01:06 EST

Identified

The issue has been identified and a fix is being implemented.
Posted Dec 18, 2025 - 00:12 EST

Investigating

Starting around 9:52pm US Eastern, a database upgrade failure caused data processing delays in-app. As a result, we are experiencing delays in event processing, flows, unsubscribes, segmentation, sending for certain campaigns, and v3 APIs. No data loss is expected. We are actively working to resolve the incident and will provide updates when possible.
Posted Dec 17, 2025 - 23:10 EST
This incident affected: Klaviyo App (Klaviyo App), Email Sending (Campaign Email Sending, Flow Email Sending), and Klaviyo API, Segmentation, Flow Triggering.