Omnichannel Campaign Resends

Incident Report for Klaviyo

Resolved

This incident has been resolved.
Posted Sep 03, 2025 - 18:56 EDT

Monitoring

We have identified the root cause and have mitigated any further incorrect resends of omnichannel campaigns. We continue to monitor closely and appreciate your patience throughout this incident.
Posted Sep 03, 2025 - 18:41 EDT

Investigating

We are currently investigating an issue where omnichannel campaigns were resent unexpectedly. We'll provide updates as soon as more information is available.
Posted Sep 03, 2025 - 17:32 EDT
This incident affected: Email Sending (Campaign Email Sending).