Delayed event processing for some Shopify users

Incident Report for Klaviyo

Resolved

This incident has been resolved.
Posted Mar 31, 2025 - 16:00 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 31, 2025 - 15:33 EDT

Identified

As of 12:00 PM (US Eastern Time) on March 31, 2025, some accounts began experiencing an up to 2 hour delay in processing Shopify’s Checkout Started and Placed Order events. The team has identified the issue and is working on a fix. No event data has been lost.
Posted Mar 31, 2025 - 14:13 EDT
This incident affected: Integrations (Integrations - Shopify).