Help Center and Klaviyo.com slowness in APAC

Incident Report for Klaviyo

Resolved

The Klaviyo Help Center and Klaviyo.com are now fully functional in the APAC region. Our third party provider identified and resolved the issue. We apologize for any disruption this may have caused.
Posted Jun 12, 2025 - 21:59 EDT

Investigating

We're experiencing performance issues with the Klaviyo Help Center and Klaviyo.com in the APAC region, due to a third party provider. Our team is currently investigating, and we appreciate your patience.
Posted Jun 12, 2025 - 21:20 EDT
This incident affected: Klaviyo.com and Klaviyo Help Center.