Issues with custom profile property availability

Incident Report for Klaviyo

Resolved

This incident has been resolved.
Posted Mar 31, 2025 - 09:38 EDT

Monitoring

Beginning at 12:02 PM US Eastern Time, Klaviyo began experiencing issues with custom profile properties appearing in drop downs throughout the app.

The root cause has been identified and addressed, custom profile property functionality has been restored. We are monitoring to confirm all impacts have been resolved and there are no further issues.
Posted Mar 27, 2025 - 13:40 EDT
This incident affected: Segmentation and Flow Triggering.