Campaign scheduling errors

Incident Report for Klaviyo

Resolved

Campaign scheduling has returned to normal operation. If you scheduled a campaign between 1:15 PM and 2:00 PM US/Eastern on August 12, 2026, we recommend checking its status and rescheduling if needed. This incident has been resolved.
Posted Aug 12, 2026 - 14:14 EDT

Monitoring

Between 1:15 PM and 2:00 PM US/Eastern on August 12, 2026, some customers experienced errors when scheduling campaigns, and some scheduled campaigns were canceled. If you scheduled a campaign during this window, we recommend checking its status in your account. A fix has been deployed and system performance is improving. We continue to monitor closely and will confirm once fully resolved.
Posted Aug 12, 2026 - 14:04 EDT
This incident affected: Campaigns (Email Sending, Text Message Sending, WhatsApp Sending, Mobile Push Sending).