As of 6:07pm (US Eastern) all messages that were delayed or failed to send properly during this window have been sent. Marking this incident as Resolved.
Posted Apr 14, 2025 - 18:08 EDT
Monitoring
As of 5:45pm (US Eastern), we have released a fix and users should no longer be experiencing this issue. Any messages that were delayed or failed to send properly during this window will be replayed or sent as normal.
Posted Apr 14, 2025 - 17:48 EDT
Identified
As of 5:30pm (US Eastern), we have identified the root cause of the issue and are working on a fix. We believe this issue also impacted segment and flow creation/editing.
Posted Apr 14, 2025 - 17:38 EDT
Investigating
We are currently investigating an issue with campaign scheduling and cloning that began at approximately 4:40pm (US Eastern). We believe this issue is also impacting campaign sending. We will continue to keep this incident updated as we investigate further.
Posted Apr 14, 2025 - 17:27 EDT
This incident affected: Email Sending (Campaign Email Sending).